
MPC 3.9 - Release Notes 
Compatibility 

This release is for MPC Key 37 G2, MPC One G2, MPC XL, MPC Live III, MPC Key 37, MPC 
One+, MPC X Special Edition, MPC Key 61, MPC One, MPC Live II, MPC X, MPC X SE, 
MPC Live and Force (standalone only). 

Desktop Software 

The MPC 3 desktop software remains in beta and now includes plug-in versions in the following 
formats: 

• Audio Unit (AU) 
• VST3 

Please note that projects created in Standalone Mode on version 3.4 to 3.9 are not backward-
compatible with the MPC 2.15 desktop software. 

Downloading the Firmware Update 

You can download the MPC 3.9 firmware update in either of the following ways: 

• MPC Standalone Updater: In standalone mode, connect your MPC to the internet, go to 
Preferences > Info, press UPDATE, then select Online Update. 

• inMusic Software Center: Visit https://www.akaipro.com/downloads-and-
support/downloads/software-center/ to get the inMusic Software Center (if you don’t 
already have it installed), then download the update from within the inMusic Software 
Center. 

For instructions on installing these updates, please visit our support page here. 

 

Key Features 

Arrange Mode Editing Tools (Touch UI) 
We’ve introduced a new set of arranging tools in the Touch UI to streamline editing and song 
structure workflow. These tools are designed to work directly with the Loop Brace, allowing 
fast and intuitive arrangement editing. 

 



New Bottom Bar Arrange F Keys 

Four new function keys have been added along the bottom of the Touch UI when working in 
Arrange Mode: 

• Cut 
• Copy 
• Paste 
• Duplicate 

These functions operate using the Loop Brace as the selection range. 

How It Works 

1. Position the Loop Brace around the section of the arrangement you want to edit. 
2. Press one of the edit functions. 

Examples: 

• Copy 
o Copies the contents inside the Loop Brace. 
o Move the playhead to a new location. 
o Press Paste to insert the copied content at the playhead position. 

• Cut 
o Removes and copies the contents inside the Loop Brace. 

• Duplicate 
o Copies the contents inside the Loop Brace. 
o Pastes the copy immediately after the selection. 
o Automatically moves the Loop Brace to the duplicated region for quick repeated 

duplication. 

Example: 
If the Loop Brace covers bars 1–3, pressing Duplicate will create a copy from bars 3–5 and 
move the Loop Brace to bars 3–5. 

 

Loop Brace Advanced Edit Menu 

You can now access additional editing commands directly from the Toolbar Edit menu. You can 
also use Double Tap the Loop Brace to bring up the same Edit menu 

Available Commands 

• Cut 
• Copy 



• Paste 
• Duplicate 
• Clear 
• Delete 
• Insert Blank Bars 
• Insert Clip Row 
• More Options… 

o Legacy editing (popup-based) options are still available via the “More Options” 
entry 

 

Insert Clip Rows 
You can now insert Clip Matrix rows directly into the arrangement. 

How to Use 

From the Arrange Edit menu select Insert Clip Row to open the new Insert Clip Row pop-up. 

Insert Clip Row Options 

• Playhead Position 
o Determines where the Clip Row will be inserted in the arrangement. 

• Bars 
o Sets how many bars the Clip Row will be inserted for. 

• Bars Follow Longest Clip 
o Automatically sets the bar length based on the longest clip in the selected row. 

• Insert Behaviour Options 
o Replace – Replaces existing content. 
o Insert – Inserts content and shifts existing arrangement data forward. 
o Close on Action – Automatically closes the pop-up after the operation is 

performed. 

 

Arrange Toolbar Updates 

• Loop On/Off has been moved from the F-key menu to the toolbar for quicker access 
• BPM field has been removed. 

 

Arrange Mode (Desktop – Beta) 



An early beta implementation of Arrange Mode has been added to the MPC Desktop software. 

Arrange Mode provides a linear, track-based view of your arrangement and enables basic 
arrangement-level editing directly from the desktop GUI. 

Accessing Arrange Mode 

Arrange Mode can be accessed via: 

• View ▸ Mode ▸ Arrange, or 
• The dedicated Arrange Mode icon in the main toolbar. 

Arrangement Editing 

In this beta implementation, Arrange Mode allows you to view and edit your arrangement using 
familiar MPC workflow concepts. 

• Use the Loop Brace to define the region to be edited. 
• Apply arrangement edits using the Cut, Copy, Paste, and Duplicate buttons in the 

Arrange toolbar. 
• Additional arrangement edit operations are available from the Edit drop-down menu in 

the Arrange toolbar. 

Edit commands operate on the Loop Brace selection, in line with the touchscreen (TUI) Arrange 
workflow. 

Track-Level Editing 

For more detailed, track-specific edits: 

• Use the Single Track Grid Editor displayed beneath the Arrange editor. 
• This allows focused editing on individual tracks while remaining in Arrange Mode. 

Note: Arrange Mode on Desktop is in beta. Feature availability and behaviour 
may change in future updates. 

 

Arrange Editing Summary 

These new Arrange Mode tools significantly speed up arrangement editing by allowing you to: 

• Quickly copy and duplicate arrangement sections 
• Perform advanced editing directly from the Loop Brace 
• Insert Clip Matrix rows directly into the timeline 



 

MPC Oscillators 
Drum and Keygroup tracks can now use oscillators as a sound generator instead of samples. 

An optional MPC Core Oscillators Expansion pack of presets is available to download from the 
inMusic Software Center. These presets provide an introduction to the creative possibilities of 
the new MPC Oscillators. 

Using MPC Oscillators 

1. On a Drum or Keygroup track, open Track Edit. 
2. In the TUI, navigate to the Samples tab. 
3. For any layer, switch the sound source from Sample to Oscillator using the Sample/Osc 

radio button. 

Some oscillator types require additional content. Click Get Oscillator Content to download the 
required MPC Oscillator Content from Preferences ▸ Activations. 

From the GUI, click the OSC button to access oscillator parameters. Use the Edit button or the 
Wave view toolbar to adjust oscillator settings. 

Oscillator Waveforms 

Warm Sine 

A sine oscillator with added harmonics for a richer tone. 

Basic Waveforms 

• Digital Sine – A pure sine oscillator. 
• Saw Square – An analog-modelled oscillator morphable between saw and square 

waveforms. 
• Digital Saw – A digital sawtooth oscillator. 
• Pulse – A square oscillator with variable pulse width. 

Advanced Waveforms 

• Noise – A noise oscillator with a variable filter. 
• FM2 – A two-operator FM oscillator. 
• RM3 – A three-operator ring-modulation oscillator, suited to metallic and harmonic 

textures. 
• Algorithmic Waveforms – A single-cycle oscillator using dynamically generated source 

shapes. 



• Single Cycle – A high-quality single-cycle oscillator using small WAV files as the sound 
source. 

• Wavetable – Supports custom wavetable formats. Wavetables are stored in folders 
containing a JSON file that defines the wavetable format. All wavetable source files must 
be mono WAV files. 

Oscillator Parameters 
All oscillators include Decay Time and Start Phase parameters. 
Additional parameters are available depending on the selected oscillator type. 

Warm Sine 

• Precision – Controls the accuracy of the synthesis algorithm. 
• Fuzz – Adds noise and harmonic texture. 

Saw / Square 

• Shape – Morphs the waveform between saw and square. 
• Tone – Reduces high-frequency content by morphing the waveform toward a sine shape. 

Digital Saw 

• Direction – Switches between saw and ramp waveforms. 

Pulse 

• Pulse Width – Adjusts the width of the pulse waveform. 

Noise 

• Tone – Controls the cutoff frequency of an internal low-pass filter. 

FM2 

• Level – Controls the amount of FM modulation applied. 
• FM Decay – Sets the decay time of the second operator. 
• Coarse – Controls the coarse pitch of the second operator. 
• Tune – Controls the fine pitch of the second operator. 
• Feedback – Sets the amount of feedback applied to the second operator. 

RM3 

• Coarse 1–3 – Controls the pitch of each operator. 
• Decay 1 – Controls the decay of the first operator. 



• Decay 2–3 – Controls the decay of the second and third operators. 

Algorithmic Waveforms and Single-Cycles 

• Feedback – Controls the amount of FM applied to the oscillator. 
• Feedback Shape – Applies waveshaping to the feedback signal. 

Wavetables 

• Position – Selects the waveform index within the wavetable. 
• XFade – Controls smoothing when transitioning between adjacent waveforms. 

Modulating Oscillator Parameters 
Oscillator parameters can be modulated via the Modulation Matrix, in the same way as other 
parameters. 

On a Keygroup track, select a wavetable oscillator on Layer 1. Open the Modulation Matrix and 
set a Source (for example, LFO 1). In Target, navigate to Layer 1, then select one of the 
following oscillator parameters: 

• Osc Start Phase 
• Osc Position 
• Osc XFade 

Select Osc Position to modulate the wavetable position with LFO 1. 

 

Using Your Own Single Cycle and Wavetable Content 
You can use your own single-cycle or wavetable files as oscillator sources, see the MPC manual 
for more details. 

 

Saving Projects and Tracks with User Oscillators 
When saving a project or track that uses user single-cycle or wavetable oscillators, MPC 
automatically copies the required oscillator assets into the project or track asset folder. This 
ensures the project can be loaded on any MPC system. 

Note : Factory oscillator content is not duplicated, as it is assumed to be installed locally. 



 

Time Signatures per Sequence & Clip 
In the latest Akai MPC Software update, you can now assign individual time signatures to both 
sequences and clips. 

Sequences (Desktop) 

• Open the Inspector panel 
• From the Sequence section locate the Time Signature field 
• Set the desired time signature for each sequence 

Clips (Desktop) 

• Open the Inspector 
• Go to the Clip section 
• Adjust the Time Signature field for the selected clip 

Standalone (TUI) 

Sequences 

• From Main Mode 
• Use the Time Signature field to set it per sequence 

Creating a Clip with a Time Signature 

1. Scroll to an empty clip slot 
2. Open the Create Clip overlay 
3. Set your desired time signature 
4. Select Create Clip 

Editing a Clip’s Time Signature 

• Open the Clip Editor 
• In the toolbar, adjust the Time Signature field 

Notes 

• Each sequence or clip can only have one time signature 
• When chaining sequences in Song Mode and using Convert Song to Sequence, time 

signature changes are converted into bar/beat/pulse positions rather than preserved as 
multiple time signatures 

• Importing a MIDI file into a sequence or clip should import its time signature. 



 

MPC One G2 & MPC Key 37 G2 – Device-Specific 
Enhancements 

• USB Audio I/O Expansion 
MPC One G2 and MPC Key 37 G2 now support up to 24 channels of input and output 
over USB audio, expanding multichannel recording and routing capabilities when using 
class-compliant devices. 

o From Preferences > Audio Device you change the USB Audio Channel Count 
between 24 in / out and 8 in / out. This improves compatibility with certain 
devices such as Android phones. 

• USB-C Host and Device Support (Standalone Mode) 
The USB-C port on MPC One G2 and MPC Key 37 G2 now supports both host and 
device functionality in standalone, enabling direct connection to USB audio interfaces, 
MIDI controllers, and storage devices without a computer. 

o The data role will typically be automatically selected, but can be manually 
adjusted while connected to another dual-role device such as a phone. This is 
done by going to Preferences > Hardware and scrolling to the bottom of the list, 
then using the USB Type-C Data Role setting to switch the role of the MPC to 
Act as device or Act as host. 

o When Act as device is selected, the MPC standalone MIDI ports and audio device 
are forwarded to and usable on the connected device. 

o When Act as host is selected, the MPC can host and manage features of a 
connected device such as its MIDI ports, file storage or audio device. 

o An additional USB Type-C Power Role setting controls whether you want to 
charge the connected dual-role device. 

• MPC Key 37 G2 now contains Ableton Live Control Mode. This can be used over USB 
on both devices. 

 

Desktop specific enhancements 
MPC 3.9 adds support for MPC One G2 and MPC Key 37 G2 in controller mode. 

Plugin Formats 

MPC Desktop now includes plug-in versions in the following formats: 

• Audio Unit (AU) 
• VST3 

DAW plug-in support 



• MPC 3 can be loaded as a plug-in within a host DAW 
• Enables use of MPC sequencing, sampling, and FX alongside DAW projects 
• Supports integration of MPC 3 into existing DAW projects, enabling workflows across 

both standalone MPC and DAW environments 

 

Smaller Enhancements 
• Save Program from Desktop Software 

You can now save MPC programs directly from the desktop software via File > Save 
Current Program. 

• Updated MPC Program File Format 
MPC program files are now saved in the MPC3 file format (JSON), aligning program 
data with the rest of the MPC file ecosystem. 

• Drum and Keygroup tracks now include two new classic analog low-pass filter models: 
Jura LP and Iona LP, derived from the AIR Jura and AIR Iona instruments. 

 

Bug Fixes 
16 Levels 

• When set to Tune - Chromatic, octave mapping has been corrected for lower pads when 
the starting pad is Pad 13 or higher. 

Activations 

• Temporary downloads directory is now correctly removed if a download from 
Activations is interrupted or fails. 

Arrange 

• Using Copy/Paste functions in arrange edit correctly copies the selected events to the 
playhead position, even if a clip is currently selected. 

Browser 

• Scroll position in the browser no longer changes during search. 

Channel Mixer 

• MPC Desktop: Resolved an issue with scrolling in the channel mixer with MPC Studio 
Mk II encoder after creating Audio tracks. 



• MPC Desktop: Submixes, Returns & Outputs can no longer be deleted. 

Grid View 

• Changing the pad bank scrolls the grid vertically to display the correct pad bank range. 
• MPC Desktop: Can now click and drag the playhead across the timeline. 
• MPC Desktop: Highlighting an area of automation with the marquee tool selected keeps 

the automation selected after releasing the mouse click. 
• MPC Desktop: Selecting automation with the marquee tool and using backspace now 

successfully removes the selected automation. 
• MPC Desktop: After selecting automation with the marquee tool, pencil and eraser tools 

now work correctly when switched to. 

Key Ranges 

• When adjusting the key range boundaries with the data dial, the minimum and maximum 
values both move incrementally when the values are next to each other. 

List Edit 

• After adjusting the length of a note event using the data dial or +/- hardware buttons, 
using undo to restore the note length also restores automation that is affected by the note 
length adjustment. 

Main Mode 

• When creating a CV track and setting to Drum the pad bank now defaults to Bank A. 
• Crash no longer occurs when using Copy Sequence on the first sequence of a loaded 

project. 
• Force: Sequence Edit menu now also includes the Copy Events function. 

Pad Perform 

• In Chords mode, when set to a Major 9th or Minor 9th chord the 7th harmonic is now 
played and recorded correctly. 

Playback & Recording 

• When recording to the sequence on an audio track, with loop set to on and the Input set to 
1 or 2, the recorded audio plays back correctly on the first loop. 

• With Clips enabled, when launch quantization is set to 4 bars, triggering a clip or clip row 
during playback will always launch at the next 4-bar boundary. 

• MPC Live III & MPC XL: When recording into a new clip, XY pad automation is now 
still recorded for a pad if the pad is triggered before the clip recording starts. 

Preferences 



• MPC Key 61/MPC Key 37: Keyboard Control settings now persist after shutdown and 
new project. 

• MPC Desktop: OK button on the Version Information popup now dismisses the popup 
correctly. 

Sample Edit 

• After creating slices in chop mode, switching to trim mode correctly shows the slices in 
the Slice combobox 

• After using the Convert to New Drum Track function the Slice combobox correctly 
shows the slices for the current pad and can be used to change the slice. 

• When creating multiple stems from the same source, a number is now appended to the 
sample name to avoid saving and loading issues where duplicate samples may be 
removed. 

Saving and Loading 

• When loading an Ableton Live project, the time signature is now imported correctly, 
resolving an issue with incorrect clip lengths. 

• It is no longer possible to access the Save selection with the Save hardware button when 
the Save As overlay is open. 

• After importing an MPC2 project, exporting one of the tracks as MIDI no longer creates a 
MIDI file with missing events. All events are exported correctly. 

• MPC Desktop: Right clicking on the sequence panel in the inspector and using Export as 
MIDI no longer creates a MIDI file with missing events. All events for the sequence are 
exported correctly. 

• MPC Desktop: Loading FX Rack in controller mode no longer repeats the function 
multiple times, resulting in faster loading time and only a single undo event. 

Sampler Mode 

• In Auto-sampler, if you enable the velocity layers and update their values, if you leave 
the dialogue and return the values are retained. 

Step Sequencer 

• MPC Live III & MPC XL: Step Sequencer no longer records a step when tapping a pad 
whilst using pad select. 

• MPC Live III & MPC XL: After clearing automation, using Add Automation and 
adjusting the value with the data dial now sets the value correctly. 

Touch Strip: 

• For devices with a Touch Strip, the Touch FX setup f-key is only available in the popup 
when Touch FX is instantiated in the project. 



Track Edit 

• For Drum tracks, the Q-link assignments are now set correctly in Screen mode for LFO, 
Utilities and Mod Matrix tabs. 

• For Keygroup tracks, with Global Poly set to Mono and Mono Retrig enabled, the 
envelopes are now applied correctly when the first held note is retriggered. 

• With an instance of Hype, a crash no longer occurs when changing presets or adjusting 
oscillator samples at critical memory. 

• For CV Tracks, with Advanced CV enabled, Mod Wheel is now available in the source 
list. 

Track View 

• Using learn to set the boundary now sets correctly if setting below the minimum or above 
the maximum. 

 

Known Issues 
• In rare cases, Audio Mixdown to .WAV can output a blank file. 
• Expert Sleepers ES-9 is known to have distortion on output when used the audio interface 

with Force and MPC units. 
• Held pad or key events stop playing when changing Sequence or Clip during playback. 
• Cancelling a Save action can fail, causing the TUI and pads to flash. 
• A crash can occur after undoing/redoing Clear Sequence when using Next Seq Step 

Sequencer mode. 
• When recording Audio Track data that overwrites existing data, the existing audio will be 

heard briefly on playback loop. 

 


