
MPC 3.7 Update 
Compatibility 

This release is for MPC XL, MPC Live III, MPC Key 37, MPC One+, MPC X Special Edition, 
MPC Key 61, MPC One, MPC Live II, MPC X, MPC X SE, MPC Live and Force (standalone 
only). 

Desktop Software 

The MPC 3 desktop software remains in beta. Please note that projects created in Standalone 
Mode on version 3.4 to 3.7 are not backward-compatible with the MPC 2.15 desktop software. 

Downloading the Firmware Update 

You can download the MPC 3.7 firmware update in either of the following ways: 

• MPC Standalone Updater: In standalone mode, connect your MPC to the internet, go to 
Preferences > Info, press UPDATE, then select Online Update. 

• inMusic Software Center: Visit to get the inMusic Software Center (if you don’t 
already have it installed), then download the update from within the inMusic Software 
Center. 

For instructions on installing these updates, please visit our support page here. 

 

Q-Link Mode: MPCe Pads 

The new MPCe Q-Link Mode transforms each MPCe pad into an expressive XY control 
surface, providing direct, hands-on modulation of synthesis and effects parameters. 

This feature bridges pad performance and real-time parameter control, offering a faster, more 
tactile alternative to traditional Q-Link knob mapping. 

XYPad Control 

Each MPCe pad can now function as a mini XY pad, transmitting X, Y, and Pressure data for 
real-time modulation of insert effects or synthesis parameters. 

You can: 



• Assign pad axis data to modulate filter cutoff, resonance, LFO depth, or any other 
assignable parameter. 

• Use empty pads within a Drum Track as dedicated modulation surfaces — similar to a 
Kaoss Pad — for controlling effects or automation. 

Q-Link Integration 

Using MPCe Q-Link Track Mode, you can map expressive pad data directly to Q-Link 
parameters. 
This enables seamless real-time control over insert effects, instrument parameters, or modulation 
routings directly from the pads. 

How to Assign Parameters 

1. On a Drum Track 
2. Open Q-Link Edit and navigate to the MPCe Pads tab. 
3. Use the Pad field to choose the pad you wish to edit. 

o Tip: Setting Pad = All allows you to make assignments that apply globally to all 
pads. 

4. Use the Control dropdown to specify whether you are editing the X-axis, Y-axis, 
Pressure, or Quadrant of a pad. 

5. Assign parameters using the [+] button or [Learn] function, just like any other Q-Link 
assignment. 

Visual Feedback 

• The TUI Pad Component provides an on-screen visualization of each pad’s X/Y 
movement, allowing intuitive tracking of modulation gestures. 

• A Pressure Graph displays real-time pressure response, making it easy to see and 
fine-tune pad sensitivity and modulation range during performance. 

Notes 

• MPCe Q-Link Mode is only accessible from a Drum Track. 
• MPCe Q-Link Mode supports both Project and Track modes. 

 

MPCe Layer → Quadrant 

We’ve made it much easier to control which MPCe Pad quadrants trigger individual Drum 
Pad Layers. 



This allows precise mapping of sounds to specific pad areas, perfect for multi-sound 
performance setups or expressive layering. 

Drum Tracks 

From a Drum Track, open Track Edit → Tune/Mix. 
Within the MPCe Pad TUI component, you can now enable or disable individual quadrants 
for each layer of a drum pad. 

For example, if Layer 1 contains a kick drum and you want it to play only from the bottom-left 
quadrant, simply turn off the other three quadrants in the MPCe Pad view. 
This lets you dedicate different sounds to different quadrants of the same pad. 

 

Modulation Matrix Target → Slice 

You can now use the Modulation Matrix to modulate the Slice number of a sample on both 
Drum and Keygroup tracks. 

This powerful addition enables dynamic, performance-based slice selection using sources such as 
Pad X position, Velocity, or other modulation inputs. 

How It Works 

Assign Target → Slice in the Modulation Matrix to dynamically change which slice of a 
sample is triggered when a note is played. 

The slice change occurs at note-on, allowing each note to select a different slice based on 
modulation input values. 

Examples 

Example 1: 
Play different slices across the X-axis of an MPCe pad. 

• Source: Pad X 
• Target: Slice 

This allows smooth, spatial control of sample slices as you move across the pad surface. 

Example 2: 
Create 128 velocity-switched layers using a single sample sliced into 128 regions. 

• Source: Velocity 



• Target: Slice 
Each velocity value triggers a corresponding slice, creating a detailed, expressive velocity 
response. 

 

Partial Pad Presets 

To accelerate sound design and creative experimentation, we’ve introduced a library of Partial 
Pad Presets for Drum Tracks. 

These presets allow you to quickly explore advanced synthesis setups, complex MPCe pad 
routings, and expressive modulation configurations — all without starting from scratch. 

Overview 

On a drum track a Partial Pad Preset contains the complete state of the synthesis engine that 
processes a pad, along with a selection of key setup parameters. 
This means you can instantly apply rich, preconfigured signal paths and modulation routings to 
any pad. 

Presets range from: 

• Filter and drum effects chains for quick sound shaping 
• MPCe expressive Mod Matrix routings for advanced performance control 

These presets deliver immediate, musical results, making it easy to experiment and evolve your 
sound. 

Loading and Saving Presets 

To load a Partial Pad Preset on a Drum Track, from the TUI go to Track Edit → Samples tab 
and use the Preset field to select a preset from the library. On the GUI use the Track Edit 
toolbar. 

You can also save and load your own custom presets, allowing you to build a personal 
collection of favorite pad processing setups for rapid recall in future projects. 

 

Step Sequencer: Extended Note Length 

You can now lengthen notes across bars and banks within Step Sequencer Drum Sequence 
Mode, enabling smoother programming of sustained notes and longer performances. 



MPC XL and MPC Live 3 when working in Step Sequencer Drum Sequence Mode, notes can 
now extend beyond the current 16-step bank. 

To lengthen a note across multiple banks: 

1. In Bank 1, press and hold a note (step) in the Step Sequencer. 
2. While holding the note, press the Next Bank button to move to Bank 2. 
3. Still holding the original note, press another Step Sequencer button in Bank 2 to define 

the new end point of the note. 

The note will now extend seamlessly across both banks, maintaining consistent timing and 
playback through the full range of steps. 

 

Q-Link Mode Step Sequence 

With this update, MPC XL and MPC Live 3 gain a powerful new Q-Link Mode: Step 
Sequencer, seamlessly integrating Q-Link control with the 1–16 hardware step sequencer for 
faster, more expressive sequencing. 

Overview 

This new mode works in conjunction with the hardware 1–16 Step Sequencer, providing 
contextual parameter control tailored to each Step Sequencer mode. 

Each mode automatically maps Q-Links to the most relevant editing parameters, allowing for 
fast, intuitive, and hands-on control during step programming. 

For example, in Drum Sequence or Note Sequence modes, Q-Links automatically adjust step 
velocity, while Step Edit mode exposes detailed per-step controls such as tuning, probability, 
and envelope shaping. 

This integration streamlines step-based composition and enhances real-time workflow when 
sequencing directly from the hardware. 

Mode Assignments 

Step 
Sequencer 

Mode 

Q-Link 
Assignment Details / Notes 

Drum Seq Velocity Fixed mapping for per-step velocity control. 
Note Seq Velocity Fixed mapping for melodic step velocity control. 



Step Edit Step Edit Screen 
parameters 

Uses the existing Step Edit Q-Link layout for the currently 
selected step:  

• Velocity  
• Ratchet  
• Probability  
• Nudge  
• Tuning  
• Tuning (Fine)  
• Level  
• Pan  
• Cutoff  
• Resonance  
• Filter Env Amount  
• Sample Slice  
• Env Attack  
• Env Decay  
• Env Release  
• Sample Layer 

Note : Changing tab in the TUI Step Edit popup changes 
the parameters displayed on the Q-Links. 

Note Length Note Length Adjusts note lengths in pulses. 
Last Step Off Q-Link inactive. 

Automation 
Selected 
Automation 
Parameter Value 

Controls the value of the currently selected automation 
parameter. 

Clip Launch Off Q-Link inactive. 

Row Launch Row Tempo 
SHIFT + tapping a Q-Link enables/disables Row Launch 
Tempo for a Clip Row. Once enabled, Q-Links can then 
be used to adjust a rows tempo. 

Track Select Volume Q-Link controls track volume. 
Track Arm Volume Q-Link controls track volume. 
Track Mute Volume Q-Link controls track volume. 
Pad Mute Pad Level Q-Link controls pad level. 

Next Seq Auto-Select Track 
When changing a sequence you can specify the track that 
will be selected. This is the same as the Sequence Settings 
Auto Select Track Field. 

Q-Link Pad 
Grid Off Q-Link inactive. 

Visuals Off Q-Link inactive. 
Edit Actions Off Q-Link inactive. 



  

 

Step Sequencer Lighting 

The Step Sequencer modes on MPC XL have been updated to improve pad legibility in bright 
lighting environments. 

Track Select Mode 

• All track colors now display at full brightness. 
• The selected track is shown as bright white for immediate visibility. 

Pad Mute Mode 

• Unmuted pads: Show their assigned color at full brightness. 
• Muted pads: Display as dim flashing amber. 
• Soloed pads: Display as dim flashing blue. 

Track Mute Mode 

• Unmuted tracks: Show their assigned color at full brightness. 
• Muted tracks: Display as dim flashing amber. 
• Soloed tracks: Display as dim flashing blue. 

Note: These lighting enhancements apply only to MPC XL hardware and are designed for 
optimal visibility during live performance and outdoor use. 

 

Step Sequencer Nudge improvements 

This update introduces refined behavior for nudging MIDI events within sequences and clips. On 
MPC XL a nudge is performed using the dedicated hardware buttons <NUDGE and NUDGE>. 
Alternatively the same function can be performed using the TUI Step Sequencer < Nudge > 
buttons. 

Consistent Event Wrapping 

• Nudging events earlier or later now keeps them locked inside the valid playable range of 
their parent clip or sequence. 

• Events that pass the end boundary wrap back to the start, and events nudged before the 
start wrap to the end. 



• Events will never appear outside the valid timeline after nudging. 

Clip-Based Event Handling 

• Events now wrap between: 
o Start point: earliest of Clip Start or Clip Loop Start 
o End point: Start + Clip Loop Length 

Example: 
Clip Start = 2:1:00 
Loop Start = 1:1:00 
Loop Length = 4 bars 
→ Events wrap between 1:1:00 and 5:1:00 

Sequence Event Handling 

• For sequence-based event lists, events wrap between: 
o 1:1:00 (start) 
o End of sequence 

• Sequence loop brace does not affect wrapping. 

Independent Track Length Support 

• When Independent Track Length is enabled, events wrap within each track's own 
length instead of the main sequence length. 

• Start remains 1:1:00 

 

Copy Arrangement to Clip Row 

You can now copy an Arrangement Row directly into a Clip Matrix Row, allowing quick 
transfer of arrangement data into a clip-based performance layout. 

This makes it easy to repurpose timeline sections for live playback, loop-based composition, or 
clip-style remixing. 

From TUI Clip Matrix Mode: 

1. Push and hold on the Arrangement Row. 
2. From the Selector, choose Copy. 
3. Navigate to the Clip Row you want to paste into. 
4. Push and hold on an empty Clip Row, then choose Paste from the Selector. 



The Arrangement event list will be copied into the selected Clip Row. 
The loop region of the new clips automatically match the loop region of the Arrangement Row. 

Example Workflow 

You can use the Arrangement Loop Brace to copy specific sections of your song into different 
Clip Rows to try out different arrangement ideas to this: 

• Set the loop brace to bars 1–5, then copy and paste that section into Clip Row 1. 
Alternatively for a fast one button workflow use the Insert and Capture option.  

• Move the loop brace to bars 5–9, then copy and paste that section into Clip Row 2. 

  

 

MPC XL - Default Chop Button Mode 

A new setting, Default Chop Button Mode, has been added for MPC XL’s dedicated CHOP 
hardware button. 
This setting allows users to define which Chop Mode is automatically used when pressing the 
CHOP button in Sample Edit. 

Behavior 

• When the CHOP button is pressed: 
o If the current sample already has slices, the system enters Sample Edit → 

Chop tab with Manual mode selected (no change to previous behavior). 
o If the current sample has no slices, the system enters Sample Edit → Chop tab 

using the user’s Default Chop Button Mode. 
• This setting does not affect any other Sample Edit behavior — including scrolling 

through samples or entering the mode through the Mode Menu. 

Location 

• Choose your default chop mode for an unsliced sample in Sample Edit → Settings 

 



MPC Live 3 specific enhancements 

Mic & Speaker Improvements 

You can now use the MPC Live 3 internal microphone while the speaker is on — making it 
faster to capture samples with the built-in mic and instantly audition them through the speaker. 

A new option in Preferences → Hardware lets you control this behavior: 
Disable internal mic while speaker is on. 

To use the mic and speaker together, set this preference to Off. 

• The mic and speaker can then be used simultaneously with no restrictions. 
• No popup is shown when enabling the mic while the speaker is on. 
• When both are active, the Monitor controls for tracks using the internal mic input are 

visibly disabled, with on-screen feedback reading: 

“Internal mic monitoring disabled while speaker is on.” 

 

Smaller Enhancements 

• On MPC Live 3 and MPC XL, you can now solo tracks and pads directly from Step 
Sequencer Mode: Track/Pad. 

o In Step Sequencer Track Mute or Pad Mute modes, hold SHIFT and tap a step 
button to solo the selected track or pad. 

o Soloed tracks and pads are indicated by flashing light blue step buttons. 
• USB Audio Channel Configuration 

o MPC Live 3 and MPC XL now include a new Preferences > Audio Device 
option that allows you to change the number of USB audio channels from 24 In / 
24 Out to 8 In / 8 Out. 

o Reducing the channel count improves compatibility with certain USB audio hosts, 
including Android devices. 

• Force Note Config. 
o Note Config now supports custom pad layouts. 
o In the Note Config dialog, Off has been renamed to Custom. 
o When Custom is enabled, Force uses the pad note map and pad colors stored 

in the program. 
o Pad note maps can be edited via the Edit Note Map dialog. 

• MPC’s with a touch strip gain a new Touch Strip Mode : Strum perfect for adding 
expressive movement to your performances. 

o When Note Strum is enabled, the Touch Strip lets you “strum” any notes you’re 
holding — just like brushing across strings on a guitar or harp. This works well 
with notes triggered from Pad Perform chords mode. 



§ Strum held notes: Swipe your finger along the strip to bring chords and 
sustained notes to life. 

§ Play seamlessly: The MPC automatically manages note states, so you can 
switch modes or change held notes without stuck or hanging notes. 

• You can now reset your Wi-Fi settings. From Preferences > Wi-Fi by holding SHIFT and 
pressing the RESET f-key. 

• When you insert notes using the MPC Step Sequencer the added notes will take into 
account your current TC Swing setting. This applies TUI/GUI step sequencer modes, the 
MPC Live 3/XL Step Sequencer buttons and the Force Step Sequencer pad mode. 

• In the MPC Standalone Browser mode there is now more consistent labeling for 
[Internal] directories. 

• When controlling plugin instruments using horizontal Track and Screen mode Q-Links 
there are now a number of minor ergonomic improvements. 

• MPC Preferences > Activations. The Activations interface (both GUI and TUI) has 
been redesigned for a better user experience. You can now filter your activations list by 
type — All, Instruments, FX, or Features — for faster navigation and easier 
management. 

• Q-Link Display. Q-Link OLED screens now provide improved value visibility during 
adjustment. When a Q-Link is touched, the parameter name temporarily hides and the 
value text enlarges, making it easier to read precise values in real time. 

• Next Sequence Mode. Unused sequences are now shown as dim yellow on the MPC 
pads, while active sequences appear bright yellow, making it easier to distinguish 
between used and unused sequences at a glance. 

Bug Fixes  

Playback: 

• Changing order of tracks during playback no longer causes audio drops. 
• Audio tracks will no longer play out of sync when Loop Start is not placed at Bar 1. 
• Stutter and audio dropouts no longer occur when switching sequences if Clip Workflow 

is enabled. 
• Reordering tracks while the transport is running will no longer cause audio to be lost on 

some tracks. 
• Metronome is now audible as expected when set to a Mono output. 
• Arrangement will no longer stop when changing internal track types while in Sync mode. 
• Switching focus to another track will no longer cut off MIDI notes received from an 

external sequencer. 

Arrange View: 

• Record on next loop start setting for audio tracks has been repaired. 
• Pasting an audio regions during clip playback no longer always places this data at the 

start of an arrangement. 

Control Surface: 



• Pad lighting behaviour when entering some menus and Modes has been improved. 

Track Edit: 

• Changing between tracks in Track Edit no longers causes audio errors. 
• MPC’s control surface will no longer drop when changing track rapidly. 
• Snap to Zero setting is now working in the Samples page. 

Main Mode: 

• Deleting a track and then undoing the action no longer breaks that track’s Independent 
Track Length setting. 

Sample Edit: 

• Tapping Cancel twice during Stems processing no longer causes a crash. 
• Processing a sample slice not longer sets slice selection to All. 

Loading and Saving: 

• Loading a project with Independent Track Length settings enabled with no value changes 
now load correctly.  

• Pressing the Menu button while the New Project > Save Project reminder dialog is 
opened no longer causes a crash. 

Startup: 

• Startup wizard behavior now respects a user’s "Do not show.." selection when MPC is 
launched. 

Sequence Edit: 

• Bounce Sequence to sample option has been restored. 
• Deleting bars will no longer remove initial automation event. 
• Copy Events now works when a specific pad's events have been selected. 
• A rare crash will no longer occurs using Copy Sequence. 

Browser: 

• Folder location shortcuts set are now accurately reflected when saving data. 

Looper: 

• Looper will record in sync when Ableton Link is enabled. 

Sampler: 



• Starting a recording with TUI buttons has been repaired. 

Q-Links: 

• Q-Link now display Pitch Bend changes correctly. 
• Q-Links are now mapped correctly for Drum Track's LFO/Utilities/Mod Matrix tabs. 
• Mod Matrix Q-Link OLED parameter value displays are now aligned with TUI display . 
• Rec Arm Q-Link now updates when a track’s Arm state changed elsewhere. 
• Custom track macros for plugins are no longer reset to default when a plugin’s preset is 

changed. 
• Volume mode Q-Links for MIDI tracks have been repaired. 

Channel Mixer: 

• Audio input is now visible in Main Mode without needing to visit Channel Mixer view 
first. 

• Audible clicks when adjusting track/pad levels have been improved. 

List Edit: 

• All values for MIDI CC parameters are now available to enter. 

Time Correct: 

• Pad lighting when Time Correct popup is displayed has been corrected. 

Grid View: 

• The grid viewport when in playback with record/overdub enabled now behaves as 
expected. 

• Grid note preview now plays referencing correct Pad X/Y automation value. 
• When editing automation, Magnifying Glass tool will no longer behave like the Pencil 

tool. 
• Automation lane display changes have been made more responsive when moving events. 

Song Mode: 

• Using Record and entering sequences with pads no longer erases the current track. 
• Using Record + Play will play back the first sequence correctly. 

Clip Matrix: 

• Edit Clip/Region will now respect current clip selection. 

Sounds Mode: 



• Selecting a plugin preset in Favorites will now change the active plugin preset. 

Pad Perform: 

• Custom MIDI mapping will no longer causes notes to draw incorrectly in Grid view. 
• Aftertouch values are now set correctly when Aftertouch is disabled. 
• Stuck notes when when using Progressions have been corrected. 

MIDI Learn: 

• Reordering track positions will no longer break learned MIDI mappings. 

Undo History: 

• Crash will no longer occur when redoing an action after Undo History has been cleared. 

  

Known Issues 

• MIDI Aftertouch and Pad X/Y Position automations are not captured when recording 
Clips to Arrange. 

• Activations including Pro Pack & Clip Workflow occasionally deactivate on startup. 
• Q-Link order is sometimes wrong in the Touch Strip config when in Q-Link mode. 
• Track Edit - Envelope decay value is hard to set as desired between 0 - 700ms due to 

acceleration. 
• Sample Edit - Start/End values can be inhereted unexpectedly after placing a sample on 

an Audio track. 
• MPC XL - Step Sequencer Track Mute buttons can get into state where a track adjacent 

to a user’s selection is muted. 
• MPCe graphic is visible in Track Edit > Tune/Mix tab for keygroups. 
• Track Mute - After duplicating/deleting a track, edits can apply to the wrong group. 
• Cancelling an MPC2 project import results in empty project with no Outputs available. 

 


