
[ACVS] MPC v3.5 Release Notes 

MPC 3.5 Beta Desktop Software 
Compatibility 
This release is for MPC Key 37, MPC One+, MPC X Special Edition, MPC Key 61, MPC One, 
MPC Live II, MPC X, MPC Live hardware, and MPC Studio II. 

MPC 3 and MPC 2 Compatibility 
• MPC 3 installs alongside MPC 2, allowing you to use both versions independently.
• Please note: Projects created in MPC 3 are not backward-compatible with MPC 2.

Software Download 
To download the MPC 3.5 desktop software and associated firmware update, please use the 
inMusic Software Center 

Note : The MPC3 Desktop Software is now activated by the inMusic Software Centre and no 
longer uses iLok copy protection. 

MPC3 Beta Introduction 

Welcome to the beta release of MPC3 desktop software — a major evolution in the MPC 
platform. MPC3 delivers a significant upgrade in both workflow efficiency and feature depth, 
introducing a streamlined approach to music production through an all-new unified track 
architecture. 

By merging tracks and programs into a single 1:1 track model, MPC3 simplifies complex 
workflows and accelerates creative momentum. Whether you're composing, editing, or mixing, 
MPC3 is designed to help you move faster and stay inspired. 

Highlights of the MPC3 Beta 

• 1:1 Track Model — Tracks and programs are now unified, streamlining routing and
editing.

• VST3 Plugin Support — Expanded plugin compatibility for modern production
environments.

• Improved drum tracks — 8 velocity layers, slice motion and other enhancements.
• Advanced Keygroup Synthesis engine.

https://www.thempcstore.com/downloads/


• More timestretch options.

Please Note: This is an Early Beta Build 

This beta version includes core elements of the MPC3 architecture, but does not represent the 
final feature set. It is designed to give users early access to the new workflow and provide 
feedback as we move toward a full release. 

Planned Features Not Yet Included in This Beta 
• Q-Link Setup
• Arranger View (GUI replacement for Track View)
• Time Signature Support
• Various GUI Enhancements

We’re excited to bring you into the future of MPC — and we can’t wait to hear what you create 
with MPC3. 

New Project Feature 

When starting MPC 3 or selecting 'New Project', MPC will now automatically load a small 
Factory Project by default. 

Factory Project Setup: 

• Drum Track Preset: A single drum track with samples loaded on pad bank A.
• Q-Link Track Layout: Configured to control the sound of the drum track.
• Effects: AIR Reverb and AIR Delay are preloaded on Returns 1 and 2.

You can change the default behavior of the new project to load an Empty Project or use an 
Autoload Project from the Preferences > Project Load/Save > New Project Behaviour 
field. 

Important Note: When importing projects into MPC3, we strongly recommend that you do not 
save over your existing MPC2 projects. Doing so will render them incompatible with MPC2, 
preventing you from reopening them in the previous version. 



MPC 3: New Look and Feel 

MPC 3 introduces a refreshed, darker visual design across the interface, including updated mixer 
and channel strip views. The overall look and feel has been enhanced to improve visual clarity 
and user experience, offering a more modern and refined workflow environment. 

Your inMusic Profile is now visible in the top-right corner of the MPC 3 interface. Clicking on 
your profile provides quick access to Preferences > Activations, where you can easily activate 
and install newly purchased plugin instruments and effects. 

New Main Mode 

Discover the enhanced Main Mode in MPC, designed to improve workflow efficiency and 
provide better visual feedback for your projects. 

Inspector Track Section Enhancements 

• On-Demand Track Creation: Tracks are now created dynamically using the “+” button
in the Inspector.

• Track Edit Menu: Right-click on the track name field to access a contextual menu with
track-specific edit commands.

• Convert Track Type: Click on the Track Type radio button to convert the current
track to a different type.

• Track Length Field: The Length field now automatically follows the sequence length
by default, or can be manually set using Bars:Beats:Pulses for precise control.

Main Mode - XL Channel Strip 

Effortlessly manage all your mixing tasks using the dual Channel Strip within the left hand 
inspector. 

• Adaptive Display
o The primary strip always reflects the currently selected track or pad.
o The secondary strip adapts contextually based on your interaction:

§ Selecting a send in the primary strip will display the corresponding return
channel in the secondary strip.

§ Adjusting the level fader in the primary strip triggers the secondary strip
to show the output path for that track or pad, providing quick access to
routing controls.



 

Sample Directly into a Pad 

On a Drum Track, you can now sample directly into an empty pad. 

How to Record into a Pad 

1. Record Ready: From Main Mode, click the transport RECORD button to put the 
transport in record-ready state. 

2. Sampling Modes: 
o Moment Toggle: Press and hold an empty pad to start recording. The sampler 

records for the exact duration the pad is pressed. 
o Toggle: Tap a pad to arm it for recording. Tap again to stop recording. If the 

sampler did not start, the pad remains empty as before. 

While a pad is recording (or waiting to start recording due to threshold settings), it illuminates 
red. 

Note: Sample recording adheres to the setup in the sampler page, respecting the inputs and 
threshold values.  

 

Tempo Automation 

You can now program the tempo of an arrangement. 

1. Main Mode > List Edit : 
o Go to the Tempo tab. 
o Use the INSERT [+] and choose Global > Sequence Tempo to add a tempo event 

at the current playhead position. 
2. Grid View Mode: 

o On any track, open the automation panel. 
o From the Automation dropdown menu, choose Sequence Tempo from the Global 

section. 

 

Simplified Channel Mixer 

The new simplified Channel Mixer is designed to make applying your mixing techniques faster 
and more intuitive. 

• 1:1 Layout: Each track now has a dedicated combined Track and Program Mixer 
Strip, streamlining navigation and control. 



• Enhanced Meter Visibility: A redesigned fader cap improves readability of channel 
strip meters, making level monitoring clearer at a glance. 

 

Track Mute / Pad Mute 

Track mute controls the Mute state of all of the tracks in you current project. 

• TUI Track Mute Settings Popup: 
o Use Track Colors: Switch the pads between showing track colors and the legacy 

mute colors. 

 

Disk Streaming 

Audio files can now be streamed directly from disk, providing enhanced performance and 
flexibility. 

Enabling Disk Streaming 

• Enable Disk Streaming: 
o Navigate to Preferences > Audio/Export. 
o Use the Disk Streaming checkbox to enable this feature. 
o Once enabled, any audio loaded or recorded onto an audio track will be streamed 

from disk. 

Sample Management 

• Sample Storage Options: 
o Default Setting: Drum and Keygroup samples are loaded into memory for rapid, 

on-demand triggering of multiple simultaneous voices. 
o Changing Sample Storage: 

§ Go to the Main Mode > Bottom Panel > Project Samples pane 
§ Filter your sample pool to show samples that are either Streaming or in 

Memory. 
§ Icons: 

§ Green waveform icon: Samples streamed from disk. 
§ White waveform icon: Samples in memory. 

§ To switch a sample from memory to streaming, Right Click the sample's 
name and choose Stream From Disk from the callout menu. 

Note: Using streamed samples with Drum and Keygroup tracks may cause performance 
issues when triggering multiple streamed voices or triggering samples at high rates. 



Organizing Samples 

• Sample List Hierarchies:
o When displayed in a combo box, the sample list is now organized into Streaming

and Memory hierarchies.
• Project Handling:

o A sample's streaming or memory state is saved and recalled with the project.
o If a project is too large to load into memory, MPC loads the project and displays

missing samples in the Project Overview with a waveform and a red minus icon.
o To load missing samples, free up memory and then use the Project Overview

screen. Press and hold the sample's name and choose Load To Memory from the
callout menu.

Disk Performance and Best Practices 

• Performance:
o Disk streaming relies on the performance of the disk. For best results, use a high

performance drive.
o Save projects to your a high performance drive to stream files from that location.
o For unsaved projects, MPC uses a temporary file location to stream audio files.

• Setting Temporary File Location:
o Go to Preferences > Project Load/Save.
o Set the Temporary File Location field to your SSD drive.

Note: Removing storage media containing your Temporary File Location will revert 
temporary file storage to MPC’s internal default location. To restore external directory 
usage, remount the storage media and reboot MPC. 

Bus Automation (Submixes/Returns/Masters) 

Buses can now be fully automated, providing enhanced control over your mixes. 

Automating Buses 

• Automate Parameters:
o Automation recording, playback, and editing on buses follow the same workflow

as other tracks.
• Viewing Automation:

o From the Inspector, Track Combo navigate to a Submix/Return/Master track then
in Grid use the automation view as normal.



 

Track Edit 

Track Edit replaces Program Edit: Tracks and programs have been combined into a single 
container to simplify the user experience. 

Drum/Keygroup Track 

• 8 Layers: 
o MPC Drum and Keygroup tracks now support up to 8 layers. 
o From the Track Edit > Samples Layers Panel, you can assign and layer up to 8 

samples on a pad/keygroup, allowing for larger velocity splits or more cycle 
layers. 

Slice Motion 

• Functionality: 
o When Slice Motion is On, each time a pad is triggered a different slice from the 

sample plays. 
o Example: Slice a hi-hat or Tamborine loop in Sample Edit Chop and assign it to a 

pad in a drum track. From GUI Wave View set the Slice field to 1 and set 
§ Motion to 

§ Increment, increments the Slice number with each new note 
event. 

§ Random, plays your slices in a random order 
§ Tap a pad repetitively or turn Note Repeat On and hold the pad to hear the 

slices play of your chopped loop play. 
§ The Cycles menu lets you choose how many of the slices are played. 

Repeats 

• Setting Repeats 
o You can now set a sample to play a number of times. 
o Load a Drum Track and go to GUI Wave View. 
o Choose pad with a sample already assigned 
o Turn Pad Loop On 
o Set the Num Repeats parameter to the number of repeats you want to hear, for 

example a value of four would play the sample four times. 
• Note: 

o Repeats after the first play will play between the Sample Loop and End point 
o The behaviour difference been Repeats = 0 or 1 is only evident when a Pads 

Sample Play parameter is set to Note On. Now when holding a note 0 = infinite 
repeats and 1 will play a sample once through. 

 



New Advanced Keygroup Synthesis Engine 

Experience a significant advancement with the introduction of the new Advanced Keygroup 
multi-sample synth engine. Boasting a deep and feature rich synthesis section teeming with 
sound design opportunities, this engine opens up a world of creative possibilities. 

New to MPC3 a whole new Advanced Keygroup synthesis engine. Load any MPC2 Keygroup 
program and go to Track Edit, from the GUI Toolbar > Global panel click the LEGACY button 
OFF. MPC preserves your existing sample keymap but switches out the legacy MPC2 Keygroup 
synthesiser for the new Advanced Keygroup engine. 

• Automatable Parameters: All synthesis parameters within the Advanced Keygroup 
section are fully automatable and assignable to Q-Links for real-time control. 

• Dual Filter Section: Allows parallel or series configuration of two filters with a blend 
control for mixing between them. 

• Advanced Envelopes: Includes Amp, Filter, Pitch, and Aux envelopes with options for 
global or per-voice behavior. 

• Multiple LFOs: Two per-voice LFOs and two global LFOs offer extensive modulation 
options. 

• Note Counter Modulation: The Note Counters can be used for stepped modulation, such 
as alternating pan positions for different voices. 

• Modulation Enhancements: 
o Two Ramps: For additional modulation shaping. 
o Timbreshift: Adjusts the timbre of a sample across the keyrange without 

affecting pitch. 
o Global and Per-Voice Drift LFOs: Adds subtle detuning for natural variation. 

• Portamento: Smooth pitch transitions between notes. 
• Unison / Harmonizer: Adds unison voices or harmonizes the sound. 
• 32-Cell Modulation Matrix: Provides extensive routing options for complex modulation 

setups. 

This engine significantly expands the sound design capabilities of the MPC, offering flexibility 
for creating dynamic, evolving sounds. 

 

Modifiers in Drum and Keygroup tracks. 

In MPC 3, each note event in Drum and Keygroup tracks can now store individual modifier 
values across multiple parameters—giving you detailed, per-note sound shaping. 

In contrast to MPC 2, which supported only a single modifier per note, MPC 3 allows each note 
to contain its own values for the following modifier types: 

• Tuning(coarse) 
• Tuning(fine) 



• Cutoff 
• Resonance 
• Filter Env Amount 
• Pan 
• Level 
• Envelope Attack 
• Envelope Decay 
• Envelope Release 
• Sample Layer 
• Sample Slice 

This gives you the potential to craft each note to have its own distinct sound and timbre. 

Modifiers vs Automation 

Modifiers are note-based and travel with the note, lasting for the full ringing duration of the 
note event. 
In contrast, automation is timeline-based, applied at a specific point in time, and not tied to 
individual notes. 

 

Warp Algorithm Choice 

MPC now offers the choice to timestretch or repitch an audio sample to synchronize it with the 
MPC sequence tempo. 

Key Features: 

• Default Algorithm: set the default timestretch algorithm to Pro Ten or Repitch. 
o You can find this setting under: 

Preferences > Audio/Export > Audio Warp and BPM Detect > Default Warp 
Algorithm. 

o Once set to Repitch, all newly created tracks, and any loaded MPC2 
programs/projects with warp enabled, will automatically use this algorithm. 

Customization: 

• Drum Tracks: 
Override the default algorithm in Wave View > Warp Algorithm Field and select 
another option. 

• Audio Tracks: 
Change the algorithm in Single Track Grid > Algorithm Field. 

Important Notes: 



• Your choice of algorithm will be saved and recalled with the project, track, or program 
files. 

 

MPC2 Project Import 

Overview 

The transition from MPC2 to MPC3 introduces significant architectural changes, most notably 
the unification of tracks and programs into a single track container. This redesign aims to 
streamline and accelerate workflow but also results in MPC2 projects not being loadable into 
MPC3 with identical behavior. 

Key Changes and Import Process 

• Unified Track Container: 
o MPC3 merges tracks and programs, simplifying the project structure and 

enhancing workflow efficiency. 
o This change means that MPC2 projects cannot be loaded directly into MPC3 with 

their original behavior intact. 
• Importing MPC2 Projects: 

o MPC3 includes an MPC2 Project Import feature that attempts to recreate MPC2 
projects as accurately as possible. 

o Upon loading an MPC2 project, MPC3 displays an MPC2 Project Import 
dialogue. 

• Default Import Behavior: 
o All Sequences Import: By default, the Import field is set to "All Sequences." 

§ MPC3 will attempt to import all sequences and tracks from the MPC2 
project. 

§ If a single track was assigned to a single program in MPC2, MPC3 will 
create a corresponding track of the same type as the original program. 

§ If multiple tracks were assigned to the same program in MPC2, MPC3 
will create one primary track of the same type as the program and 
subsequent tracks will be MIDI tracks with their SEND TO field pointing 
to the primary track. 

• Importing Selected Sequences: 
o Selected Sequences Import: Users can choose to import only specific sequences. 

§ Setting the Import field to "Selected Sequences" displays a list of 
sequences used in the source project. 

o Users can tick the sequences they wish to import. 
o The selected sequences will load into their original locations within the sequence 

list. 

 



Smaller enhancements and changes 

Grid View 

• Grid View mode has been updated to work with the 1:1 track layout. 
• After making a recording and entering Grid View mode, by default grid view will zoom 

and scroll to show the recorded events. 

List Edit 

• List Edit mode has been updated to work with the 1:1 track layout. 
• List Edit gains Events and Tempo tabs  

Pad Color 

• To access Pad Color from the GUI go to Edit > Track > Pad Color. 
• You can now give all track types their own color maps. 
• There is now the option for a tracks pads to follow a Pad Color map (PAD) or the Track 

Color (FOLLOW TRACK) 

Browser 

• Browser mode has been updated to work with the 1:1 track layout. 
• By default loading a drum program onto an existing Drum Track replaces the track and 

its sample content with the new kit. This enables a fast workflow where drum kits can be 
loaded over each other without filling your memory with unused samples (in the right 
Browser panel > File Browser This behaviour can be toggled Off by pressing the Settings 
icon and from Browser Options, untick On Load Replace Unused Samples). 

• Track files now save with their accompanying sequence event data, allowing for more 
complete recall of musical ideas. 

o In the Media Browser, a new option—“Load Sequence”—is available at the 
bottom of the screen. 

o When enabled, loading a track file will also import the associated sequence 
events, restoring both the track settings and its musical content. 

Looper 

• The Looper now Exports to Audio Tracks. 

Known issues 

• MPC device included synths do not show in Sounds mode when desktop versions are also 
installed 

• Activations list not accurate on first start up after installation 



• With MPC Studio Mk II the Zoom is not working in Main mode WAVE or Sample Edit 
modes 

• Hang can occur after creating 60+ Drum tracks 
• Loading a non-4/4 project results in playback issues - extra beats are incorrectly played 
• Edit Menu Functions - Edit > Cut, Copy, and Paste menu items are not working, though 

their keyboard shortcuts still function correctly 
• Projects saved in MPC2 (v2.15) load with Drum/Keygroup LFO destinations reset to 0 in 

MPC3 
• Vertical drag intended for zooming the grid instead scrolls the timeline past the end of the 

sequence 
• In Create Stems, tapping a pad changes the sample that is being processed 
• Toggling effects on/off on 2 or more simultaneously causes UI to become out of sync 
• Using Bounce to Audio Track does not Mute the original track 
• VST3 and AU AIR plugins are missing Track Edit GUI elements and displaying empty 

popout windows 

 


